RangerMSP Business Automation for successful ITs


Go Back   RangerMSP Forums > RangerMSP Software Discussion Forum (CCRM)
Register Search Today's Posts Mark Forums Read

Thread Tools Search this Thread
 
August 5th, 2022, 09:33 AM
AN-Tech
 
Posts: 469
Anyone else start to get this message from Ranger and have it not able to pull in new email recently?

I suspect this is related to Microsoft disabling Basic Authentication or App Passwords again even though it wasn't supposed to happen until October. Nothing has changed on our end recently and the account isn't requiring a password change or anything. We had this happen a couple of months ago and it was failing for a few days even though nothing showed in the logs. I noticed some other people who were able to get Microsoft to admit that basic authentication and app passwords had been disabled even though they weren't supposed to and thing in the tenant indicated this.

If this is what is going on the only solution may be to get Modern Authentication working right away with Ranger. I have that request in discussion in another thread though. This one is just to find out if anyone else is experiencing this.

Thanks
 
August 5th, 2022, 09:47 AM
Support Team
 
Posts: 7,449
Yes, this should be related and Microsoft sometimes disable Basic Authentication, however, it can get re-enabled. Also, as posted in the other thread you mentioned, we'll be releasing a version that does not require basic auth anymore.
 
August 5th, 2022, 10:13 AM
AN-Tech
 
Posts: 469
Unfortunately re-enabling it doesn't work as it still shows enabled. Also disabling, waiting a bit, and re-enabling does not work either. We are currently stuck. Have others reported this as happening recently as well?
 
August 5th, 2022, 10:19 AM
Support Team
 
Posts: 7,449
Nope, enabling it, as described in this Microsoft's article (Under the 'Limited Opt Out' section), has always worked when MS auto-disabled it. Please review and see whether there are any differences or additional settings that are requried.

Hope this helps!
 
August 5th, 2022, 11:19 AM
AN-Tech
 
Posts: 469
In case it helps anyone else. Looking at the Admin Center under Settings\Org Settings\Modern Authentication showed Basic Authentication was enabled for POP3 even though Ranger wasn't working. Using the instructions from the article above and choosing to enable POP resolved the issue. So you can't enable/disable the way you would expect to you have to use the method in the article.

Keep in mind though that performing this step is a breach of your Microsoft Partner Agreement.
 
August 12th, 2022, 02:07 AM
partech
 
Posts: 12
Thanks AN-Tech. Your advise worked for us.
 
Yesterday, 06:39 AM
Support Team
 
Posts: 7,449
Update: Support for Microsoft 365 modern authentication for Email (OAuth) was introduced in RangerMSP 30.
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search



All times are GMT -6. The time now is 04:12 PM.

Archive - Top    

RangerMSP - A PSA software designed for MSPs and IT Services Providers
Forum Software Powered by vBulletin® Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.